IPv4 Address:-
IPv6 Address:-
Service Provider:-
SSL Information:-
HTTP Protocol:-
Database:-
Web:-
NDIS WiFi Drivers in FreeBSD (Project Evil) [25/Jan/2010]   Encrypted swap space     WiFi configuration in FreeBSD (including WPA/WPA2)  

WARNING: This post has been marked as obsolete and may be incorrect. It is kept for archival purposes only. Sooo... if you have a WiFi card that doesn't have native FreeBSD drivers, you might be able to use 'Project Evil' to wrap around the Windows driver for the card.  I had to do this on my new netbook...

First, you should install libiconv if you haven't already.  The easiest way is to do:

pkg_add -r libiconv Copy

Next, you need to obtain the Windows driver for the network card (I find that windows 2000 drivers are generally the most reliable).  You need the .INF and .SYS files from the driver package.  Place these somewhere on your FreeBSD computer (I put mine into /drv/)

Now we need to convert them into an NDIS kernel module...  In my case, the files are called net8192se.inf and rtl8192se.sys (RealTek 8191SE 802.11n wireless).  To convert them, type (as root):

ndisgen /drv/net8192se.inf /drv/rtl8192se.sys Copy

Press enter until you're returned to the command prompt, and you will now see a .ko file with the kernel module in.  This is named after the .sys file – so in my case, it is called rtl8192se_sys.ko.  Copy this file to the /boot/modules/ folder like so:

mv rtl8192se_sys.ko /boot/modules/ Copy

and you can activate it by adding the following line to /boot/loader.conf:

rtl8192se_sys_load="YES" Copy

You can also load the driver without rebooting by typing:

kldload rtl8192se_sys Copy

This will give you some output to the console – e.g. on my netbook:

ndis0: <Realtek RTL8191SE Wireless LAN 802.11n PCI-E NIC> port 0x3000-0x30ff mem 0xfa000000-0xfa003fff irq 17 at device 0.0 on pci3
ndis0: [ITHREAD]
ndis0: NDIS API version: 5.1 Copy


If you get this far, you should be ready to go.  Check my other posts for how to configure WiFi in FreeBSD.

  Encrypted swap space     WiFi configuration in FreeBSD (including WPA/WPA2)  
Copyright © 2024 Daniel Austin MBCS.
Proudly hosted using the FreeBSD operating system.
 
E-mail me
PGP Key
E-mail me
LOGGED IN
Login
padlock icon
LOGIN ERROR#123: random error here